Libre.fm - Upgrading database – Incident details

People are scrobbling experiencing major outage

Email support@libre.fm for any/all support.

Upgrading database

Resolved
Major outage
Started 10 months agoLasted about 4 hours

Affected

Libre.fm database

Under maintenance from 11:21 PM to 1:26 AM, Major outage from 1:26 AM to 3:27 AM

Libre.fm primary web server

Operational from 11:21 PM to 3:27 AM

Libre.fm load balancer

Operational from 11:21 PM to 3:27 AM

Libre.fm submissions over HTTP (not secure)

Major outage from 11:21 PM to 3:27 AM

Can we load a user profile? (Checked every hour)

Operational from 11:21 PM to 3:27 AM

Updates
  • Resolved
    UTC
    Resolved

    Going to close this out for now. Everything is looking good. Thanks for using Libre.fm.

  • Monitoring
    UTC
    Monitoring

    The database has been upgraded for the first time in a decade. Now using Postgres 18 instead of 9.

    Just waiting on some final steps to finish but the site is running, people are scrobbling...

  • Identified
    UTC
    Identified

    Just making sure a full and complete backup is made before proceeding. That's wrapping up now.

  • Investigating
    UTC
    Investigating

    Things may be slow while the upgrade is underway.